ARM: 5776/1: Check compiler version and EABI support when adding ARM unwind support.
authorClaudio Scordino <claudio@evidence.eu.com>
Fri, 30 Oct 2009 11:06:05 +0000 (12:06 +0100)
committerMatt Sealey <matt@genesi-usa.com>
Sat, 22 Jan 2011 04:10:01 +0000 (22:10 -0600)
commit317bf667ed78588e5f6bd8098fbfc628d2299b26
treeba072f42ee5788ff0b718cda3c93787276c5cf7e
parente7750c729d1c7ea78276e0b9d6f91ad421e011db
ARM: 5776/1: Check compiler version and EABI support when adding ARM unwind support.

ARM unwind is known to compile only with EABI and not-buggy compilers.
The problem is not the unwinding information but the -fno-frame-pointer
option added as a result of !CONFIG_FRAME_POINTER.  Now we check the
compiler and raise a #warning in case of wrong compiler.

Signed-off-by: Claudio Scordino <claudio@evidence.eu.com>
Signed-off-by: Russell King <rmk+kernel@arm.linux.org.uk>
arch/arm/kernel/unwind.c