QT5 compatability fix
[hypercube:hypercube.git] / GUI / main.cpp
1 #include <QApplication>
2 #include <QTranslator>
3 #include "GUI/gui.h"
4 #include "GUI/icons.h"
5
6
7 int main(int argc, char *argv[])
8 {
9         QApplication app(argc, argv);
10
11         QString locale = QLocale::system().name();
12         QTranslator translator;
13         translator.load(QString("hypercube_") + locale);
14         app.installTranslator(&translator);
15
16         GUI gui;
17         gui.setWindowIcon(QIcon(QPixmap(APP_ICON)));
18         gui.show();
19
20         for (int i = 1; i < argc; i++)
21                 gui.openFile(argv[i]);
22
23         return app.exec();
24 }