2 # spec file for package obs-server
4 # Copyright (c) 2008 SUSE LINUX Products GmbH, Nuernberg, Germany.
5 # This file and all modifications and additions to the pristine
6 # package are under the same license as the package itself.
8 # Please submit bugfixes or comments via http://bugs.opensuse.org/
14 Summary: The openSUSE Build Service -- Server Component
19 Group: Productivity/Networking/Web/Utilities
20 Url: http://en.opensuse.org/Build_Service
21 BuildRoot: /var/tmp/%name-root
22 # git clone git://gitorious.org/opensuse/build-service.git build-service-1.7.54; tar cfvj obs-server-1.7.54.tar.bz2 --exclude=.git\* build-service-1.7.54/
23 Source: obs-server-%version.tar.bz2
24 # git clone git://gitorious.org/opensuse/themes.git opensuse-themes-0.9; tar cfvj opensuse-themes-0.9.tar.bz2 --exclude=.git\* opensuse-themes-0.9
25 Source1: opensuse-themes-2.0.tar.bz2
27 BuildRequires: python-devel
28 BuildRequires: obs-common
29 # make sure this is in sync with the RAILS_GEM_VERSION specified in the
30 # config/environment.rb of the various applications.
31 # atm the obs rails version patch above unifies that setting among the applications
32 # also see requires in the obs-server-api sub package
33 BuildRequires: rubygem-rails-2_3 >= 2.3.5
34 BuildRequires: rubygem-rmagick
35 BuildRequires: build >= 2009.05.04
36 BuildRequires: perl-BSSolv
37 BuildRequires: lighttpd
38 Requires: build >= 2009.05.04
40 # Required by source server
41 Requires: patch diffutils
44 %if 0%{?suse_version} >= 1030
47 %if 0%{?suse_version:1}
48 PreReq: %fillup_prereq %insserv_prereq permissions
51 %if 0%{?suse_version} >= 1020
52 Recommends: yum yum-metadata-parser repoview dpkg
53 Recommends: createrepo
54 Conflicts: createrepo < 0.9.8
55 Recommends: deb >= 1.5
57 Recommends: openslp-server
59 Conflicts: obs-signd < 2.1.1
61 Requires: yum yum-metadata-parser dpkg
62 Requires: createrepo >= 0.4.10
64 Requires: perl-Compress-Zlib perl-Net_SSLeay perl-Socket-MsgHdr perl-XML-Parser
69 The openSUSE Team <opensuse-buildservice@opensuse.org>
71 %package -n obs-worker
72 Requires: perl-TimeDate screen curl perl-XML-Parser perl-Compress-Zlib cpio
73 # For runlevel script:
75 Recommends: openslp lvm2
76 # requires from build script
77 Requires: bash binutils
78 Summary: The openSUSE Build Service -- Build Host Component
79 Group: Productivity/Networking/Web/Utilities
81 PreReq: %fillup_prereq %insserv_prereq
83 %if 0%{?suse_version} <= 1030
86 %if 0%{?suse_version} >= 1120
88 Requires: util-linux >= 2.16
98 %description -n obs-worker
99 This is the obs build host, to be installed on each machine building
100 packages in this obs installation. Install it alongside obs-server to
101 run a local playground test installation.
104 Summary: The openSUSE Build Service -- The Frontend part
105 Group: Productivity/Networking/Web/Utilities
107 %if 0%{?suse_version}
108 PreReq: %fillup_prereq %insserv_prereq
111 Requires: lighttpd ruby-fcgi lighttpd-mod_magnet mysql ruby-mysql
112 # make sure this is in sync with the RAILS_GEM_VERSION specified in the
113 # config/environment.rb of the various applications.
114 Requires: rubygem-rack = 1.0.1
115 Requires: rubygem-rails-2_3 >= 2.3.5
116 Conflicts: rubygem-rails-2_3 = 2.3.6
117 Conflicts: rubygem-rails-2_3 = 2.3.7
118 Requires: rubygem-libxml-ruby
119 Requires: rubygem-daemons
120 Requires: rubygem-delayed_job
121 %if 0%{?suse_version} >= 1020
122 Supplements: ruby-ldap
124 # requires for webui:
125 Requires: ghostscript-fonts-std
126 Requires: rubygem-gruff
127 Requires: rubygem-sqlite3
128 Requires: rubygem-rmagick
129 Requires: rubygem-exception_notification < 2.0
130 Recommends: memcached
131 Group: Productivity/Networking/Web/Utilities
132 Summary: The openSUSE Build Service -- The Frontend part
134 %description -n obs-api
135 This is the API server instance, and the web client for the
138 %package -n obs-source_service
139 Summary: The openSUSE Build Service -- source service daemon
140 Group: Productivity/Networking/Web/Utilities
141 # Our default services, used in osc and webui
142 Recommends: obs-service-download_url
143 Recommends: obs-service-verify_file
145 %description -n obs-source_service
146 The OBS source service is a component to modify submitted sources
147 on the server side. This may include source checkout, spec file
148 generation, gpg validation, quality checks and other stuff.
150 This component is optional and not required to run the service.
153 %package -n obs-productconverter
154 Summary: The openSUSE Build Service -- product definition utility
155 Group: Productivity/Networking/Web/Utilities
156 # For perl library files, TODO: split out obs-lib subpackage?
159 %description -n obs-productconverter
160 bs_productconvert is a utility to create Kiwi- and Spec- files from a
163 %package -n obs-utils
164 Summary: The openSUSE Build Service -- utilities
165 Group: Productivity/Networking/Web/Utilities
166 Requires: osc build ruby
168 %description -n obs-utils
169 obs_mirror_project is a tool to copy the binary data of a project from one obs to another
170 obs_project_update is a tool to copy a packages of a project from one obs to another
172 Authors: Susanne Oberhauser, Martin Mohring
174 #--------------------------------------------------------------------------------
176 %setup -q -n build-service-%version -b 1
177 # drop build script, we require the installed one from own package
179 find . -name .git\* -o -name Capfile -o -name deploy.rb | xargs rm -rf
191 # First install all dist files
194 # configure lighttpd web service
195 mkdir -p $RPM_BUILD_ROOT/etc/lighttpd/vhosts.d/
196 install -m 0644 obs.conf $RPM_BUILD_ROOT/etc/lighttpd/vhosts.d/
197 install -m 0644 rails.include $RPM_BUILD_ROOT/etc/lighttpd/vhosts.d/rails.inc
198 install -m 0644 cleanurl-v5.lua $RPM_BUILD_ROOT/etc/lighttpd/
199 # install obs mirror script and obs copy script
200 install -d -m 755 $RPM_BUILD_ROOT/usr/sbin/
201 install -m 0755 obs_mirror_project obs_project_update $RPM_BUILD_ROOT/usr/sbin/
202 # install runlevel scripts
203 install -d -m 755 $RPM_BUILD_ROOT/etc/init.d/
204 for i in obssrcserver obsrepserver obsscheduler obsworker obspublisher obsdispatcher \
205 obssigner obswarden obsapidelayed obswebuidelayed obsapisetup obsstoragesetup \
208 $RPM_BUILD_ROOT/etc/init.d/
209 ln -sf /etc/init.d/$i $RPM_BUILD_ROOT/usr/sbin/rc$i
212 install -d -m 755 $RPM_BUILD_ROOT/etc/logrotate.d/
213 for i in obs-api.logrotate obs-build.logrotate obs-server.logrotate ; do
215 $RPM_BUILD_ROOT/etc/logrotate.d/
218 FILLUP_DIR=$RPM_BUILD_ROOT/var/adm/fillup-templates
219 install -d -m 755 $FILLUP_DIR
220 install -m 0644 sysconfig.obs-server sysconfig.obs-worker $FILLUP_DIR/
222 CRON_DIR=$RPM_BUILD_ROOT/etc/cron.d
223 install -d -m 755 $CRON_DIR
224 install -m 0644 crontab.obs-api $CRON_DIR/obs-api
225 install -m 0644 crontab.obs-webui $CRON_DIR/obs-webui
226 # install SLP registration files
227 SLP_DIR=$RPM_BUILD_ROOT/etc/slp.reg.d/
228 install -d -m 755 $SLP_DIR
229 install -m 644 obs.source_server.reg $SLP_DIR/
230 install -m 644 obs.repo_server.reg $SLP_DIR/
231 # create symlink for product converter
232 mkdir -p $RPM_BUILD_ROOT/usr/bin
233 cat > $RPM_BUILD_ROOT/usr/bin/obs_productconvert <<EOF
235 exec /usr/lib/obs/server/bs_productconvert "\$@"
237 chmod 0755 $RPM_BUILD_ROOT/usr/bin/obs_productconvert
238 cat > $RPM_BUILD_ROOT/usr/sbin/obs_admin <<EOF
240 exec /usr/lib/obs/server/bs_admin "\$@"
242 chmod 0755 $RPM_BUILD_ROOT/usr/sbin/obs_admin
243 cat > $RPM_BUILD_ROOT/usr/sbin/obs_serverstatus <<EOF
245 exec /usr/lib/obs/server/bs_serverstatus "\$@"
247 chmod 0755 $RPM_BUILD_ROOT/usr/sbin/obs_serverstatus
251 # Install all web and api parts.
254 for i in api webui; do
255 mkdir -p $RPM_BUILD_ROOT/srv/www/obs/
256 cp -a $i $RPM_BUILD_ROOT/srv/www/obs/$i
258 rm $RPM_BUILD_ROOT/srv/www/obs/api/README_LOGIN
259 rm $RPM_BUILD_ROOT/srv/www/obs/api/files/specfiletemplate
260 mkdir -p $RPM_BUILD_ROOT/srv/www/obs/api/log
261 mkdir -p $RPM_BUILD_ROOT/srv/www/obs/webui/log
262 touch $RPM_BUILD_ROOT/srv/www/obs/{webui,api}/log/production.log
263 rm $RPM_BUILD_ROOT/srv/www/obs/webui/README.install
264 # the git webinterface tries to connect to api.opensuse.org by default
265 install -m 0644 ../dist/webui-production.rb $RPM_BUILD_ROOT/srv/www/obs/webui/config/environments/production.rb
266 # needed for correct permissions
267 touch $RPM_BUILD_ROOT/srv/www/obs/webui/db/database.db
270 #set default api on localhost for the webui
272 mv $RPM_BUILD_ROOT/srv/www/obs/api/files/distributions.xml.template $RPM_BUILD_ROOT/srv/www/obs/api/files/distributions.xml
273 sed 's,FRONTEND_HOST.*,FRONTEND_HOST = "127.0.42.2",' \
274 $RPM_BUILD_ROOT/srv/www/obs/webui/config/environments/development.rb > tmp-file \
275 && mv tmp-file "$RPM_BUILD_ROOT/srv/www/obs/webui/config/environments/development.rb"
276 sed 's,FRONTEND_PORT.*,FRONTEND_PORT = 80,' \
277 $RPM_BUILD_ROOT/srv/www/obs/webui/config/environments/development.rb > tmp-file \
278 && mv tmp-file "$RPM_BUILD_ROOT/srv/www/obs/webui/config/environments/development.rb"
279 sed 's,api.opensuse.org,127.0.42.2,' \
280 $RPM_BUILD_ROOT/srv/www/obs/webui/app/helpers/package_helper.rb > tmp-file \
281 && mv tmp-file "$RPM_BUILD_ROOT/srv/www/obs/webui/app/helpers/package_helper.rb"
284 # Install webui theme
286 mkdir -p "$RPM_BUILD_ROOT/srv/www/obs/webui/public/themes/"
287 cp -av "$RPM_BUILD_DIR"/opensuse-themes-*/* "$RPM_BUILD_ROOT/srv/www/obs/webui/public/themes/"
292 mkdir -p $RPM_BUILD_ROOT/srv/www/obs/api/public/apidocs/html/
293 cp -a ../docs/api/html $RPM_BUILD_ROOT/srv/www/obs/api/public/apidocs
294 mkdir -p $RPM_BUILD_ROOT/srv/www/obs/docs/api
295 cp -a ../docs/api/api/*.{rng,xsd} $RPM_BUILD_ROOT/srv/www/obs/docs/api
297 # Fix symlinks to common, could be much cleaner ...
299 rm -f $RPM_BUILD_ROOT/srv/www/obs/api/lib/common $RPM_BUILD_ROOT/srv/www/obs/webui/lib/common
300 ln -sf /srv/www/obs/common/lib $RPM_BUILD_ROOT/srv/www/obs/api/lib/common
301 ln -sf /srv/www/obs/common/lib $RPM_BUILD_ROOT/srv/www/obs/webui/lib/common
302 ln -sf /srv/www/obs/common/images $RPM_BUILD_ROOT/srv/www/obs/api/public/images/common
303 ln -sf /srv/www/obs/common/images $RPM_BUILD_ROOT/srv/www/obs/webui/public/images/common
304 ln -sf /srv/www/obs/docs/api $RPM_BUILD_ROOT/srv/www/obs/api/public/schema
306 # change script names to allow to start them with startproc
308 mv $RPM_BUILD_ROOT/srv/www/obs/api/script/delayed_job{,.api}
309 mv $RPM_BUILD_ROOT/srv/www/obs/webui/script/delayed_job{,.web}
312 # Install all backend parts.
315 # we use external build script code
317 cp BSConfig.pm.template BSConfig.pm
319 install -d -m 755 $RPM_BUILD_ROOT/usr/lib/obs/server/
320 install -d -m 755 $RPM_BUILD_ROOT/usr/lib/obs/server/build # dummy, it is a %ghost
321 install -d -m 755 $RPM_BUILD_ROOT/srv/obs/log
322 install -d -m 755 $RPM_BUILD_ROOT/srv/obs/run
323 # install executables and code
324 cp -a * $RPM_BUILD_ROOT/usr/lib/obs/server/
325 rm -r $RPM_BUILD_ROOT/usr/lib/obs/server/testdata
326 rm $RPM_BUILD_ROOT/usr/lib/obs/server/Makefile.PL
327 # create symlink to build scritps
328 #rm -rf $RPM_BUILD_ROOT/usr/lib/obs/server/build
329 #ln -sf /usr/lib/build $RPM_BUILD_ROOT/usr/lib/obs/server/build
332 # turn duplicates into hard links
334 #%fdupes $RPM_BUILD_ROOT/srv/www/obs/api
335 #%fdupes $RPM_BUILD_ROOT/srv/www/obs/webui
336 # There's dupes between webui and api:
337 %if 0%{?suse_version} >= 1030
338 %fdupes $RPM_BUILD_ROOT/srv/www/obs
342 /usr/sbin/groupadd -r obsrun 2> /dev/null || :
343 /usr/sbin/useradd -r -o -s /bin/false -c "User for build service backend" -d /usr/lib/obs -g obsrun obsrun 2> /dev/null || :
346 /usr/sbin/groupadd -r obsrun 2> /dev/null || :
347 /usr/sbin/useradd -r -o -s /bin/false -c "User for build service backend" -d /usr/lib/obs -g obsrun obsrun 2> /dev/null || :
350 for service in obssrcserver obsrepserver obsdispatcher obsscheduler obspublisher obswarden obssigner obsstoragesetup ; do
351 %stop_on_removal $service
355 %stop_on_removal obsworker
359 %{fillup_and_insserv -n obs-server}
360 for service in obssrcserver obsrepserver obsdispatcher obsscheduler obspublisher obswarden obssigner obsstoragesetup ; do
361 %restart_on_update $service
364 %preun -n obs-source_service
365 %stop_on_removal obsservice
367 %post -n obs-source_service
368 %restart_on_update obsservice
371 # this changes from directory to symlink. rpm can not handle this itself.
372 if [ -e /usr/lib/obs/server/build -a ! -L /usr/lib/obs/server/build ]; then
373 rm -rf /usr/lib/obs/server/build
375 if [ ! -e /usr/lib/obs/server/build ]; then
376 ln -sf ../../build /usr/lib/obs/server/build
381 %verifyscript -n obs-server
385 %{fillup_and_insserv -n obs-worker}
386 %restart_on_update obsworker
389 %{fillup_and_insserv -n obs-server}
390 if [ -e /srv/www/obs/webclient/config/database.yml ] && [ ! -e /srv/www/obs/webui/config/database.yml ]; then
391 cp /srv/www/obs/webclient/config/database.yml /srv/www/obs/webui/config/database.yml
393 if [ -e /srv/www/obs/frontend/config/database.yml ] && [ ! -e /srv/www/obs/api/config/database.yml ]; then
394 cp /srv/www/obs/frontend/config/database.yml /srv/www/obs/api/config/database.yml
396 # updaters can keep their production_slave config
397 for i in production_slave.rb production.rb development_base.rb; do
398 if [ -e /srv/www/obs/webclient/config/environments/$i ] && [ ! -e /srv/www/obs/webui/config/environments/$i ]; then
399 cp /srv/www/obs/webclient/config/environments/$i /srv/www/obs/webui/config/environments/$i
401 if [ -e /srv/www/obs/frontend/config/environments/$i ] && [ ! -e /srv/www/obs/api/config/environments/$i ]; then
402 cp /srv/www/obs/frontend/config/environments/$i /srv/www/obs/api/config/environments/$i
405 if [ -e /etc/lighttpd/vhosts.d/obs.conf ]; then
406 sed -i -e 's,/srv/www/obs/webclient,/srv/www/obs/webui,' \
407 -e 's,/srv/www/obs/frontend,/srv/www/obs/api,' \
408 /etc/lighttpd/vhosts.d/obs.conf
410 echo '**** Keep in mind to run rake db:migrate after updating this package (read README.UPDATERS) ****'
411 %restart_on_update lighttpd
417 rm -rf $RPM_BUILD_ROOT
420 %defattr(-,root,root)
423 %dir /usr/lib/obs/server
424 /etc/logrotate.d/obs-server.logrotate
425 /etc/init.d/obsdispatcher
426 /etc/init.d/obspublisher
427 /etc/init.d/obsrepserver
428 /etc/init.d/obsscheduler
429 /etc/init.d/obssrcserver
430 /etc/init.d/obswarden
431 /etc/init.d/obssigner
432 /etc/init.d/obsstoragesetup
434 /usr/sbin/obs_serverstatus
435 /usr/sbin/rcobsdispatcher
436 /usr/sbin/rcobspublisher
437 /usr/sbin/rcobsrepserver
438 /usr/sbin/rcobsscheduler
439 /usr/sbin/rcobssrcserver
440 /usr/sbin/rcobswarden
441 /usr/sbin/rcobssigner
442 /usr/sbin/rcobsstoragesetup
443 /usr/lib/obs/server/BSAccess.pm
444 /usr/lib/obs/server/BSBuild.pm
445 /usr/lib/obs/server/BSConfig.pm.template
446 /usr/lib/obs/server/BSEvents.pm
447 /usr/lib/obs/server/BSFileDB.pm
448 /usr/lib/obs/server/BSHTTP.pm
449 /usr/lib/obs/server/BSHandoff.pm
450 /usr/lib/obs/server/BSRPC.pm
451 /usr/lib/obs/server/BSServer.pm
452 /usr/lib/obs/server/BSServerEvents.pm
453 /usr/lib/obs/server/BSSrcdiff.pm
454 /usr/lib/obs/server/BSSSL.pm
455 /usr/lib/obs/server/BSStdServer.pm
456 /usr/lib/obs/server/BSUtil.pm
457 /usr/lib/obs/server/BSVerify.pm
458 /usr/lib/obs/server/BSDB.pm
459 /usr/lib/obs/server/BSDBIndex.pm
460 /usr/lib/obs/server/BSXPathKeys.pm
461 /usr/lib/obs/server/BSWatcher.pm
462 /usr/lib/obs/server/BSXML.pm
463 /usr/lib/obs/server/BSXPath.pm
464 /usr/lib/obs/server/BSProductXML.pm
465 /usr/lib/obs/server/BSKiwiXML.pm
466 %dir /usr/lib/obs/server/Meta
467 /usr/lib/obs/server/Meta.pm
468 /usr/lib/obs/server/Meta/Debmd.pm
469 /usr/lib/obs/server/Meta/Rpmmd.pm
470 /usr/lib/obs/server/Meta/Susetagsmd.pm
471 /usr/lib/obs/server/COPYING
472 /usr/lib/obs/server/DESIGN
473 /usr/lib/obs/server/License
474 /usr/lib/obs/server/README
475 /usr/lib/obs/server/TODO
476 /usr/lib/obs/server/XML
477 /usr/lib/obs/server/bs_admin
478 /usr/lib/obs/server/bs_dispatch
479 /usr/lib/obs/server/bs_publish
480 /usr/lib/obs/server/bs_repserver
481 /usr/lib/obs/server/bs_sched
482 /usr/lib/obs/server/bs_serverstatus
483 /usr/lib/obs/server/bs_srcserver
484 /usr/lib/obs/server/bs_worker
485 /usr/lib/obs/server/bs_signer
486 /usr/lib/obs/server/bs_sshgit
487 /usr/lib/obs/server/bs_warden
488 /usr/lib/obs/server/worker
489 /usr/lib/obs/server/BSHermes.pm
490 /usr/lib/obs/server/BSSolv.pm
491 /usr/lib/obs/server/BSSolv.xs
492 /usr/lib/obs/server/typemap
493 %config(noreplace) /usr/lib/obs/server/BSConfig.pm
494 %config(noreplace) /etc/slp.reg.d/*
495 %attr(-,obsrun,obsrun) /srv/obs
496 /var/adm/fillup-templates/sysconfig.obs-server
497 # created via %post, since rpm fails otherwise while switching from
498 # directory to symlink
499 %ghost /usr/lib/obs/server/build
501 %files -n obs-source_service
502 %defattr(-,root,root)
503 /etc/init.d/obsservice
504 /usr/sbin/rcobsservice
505 /usr/lib/obs/server/bs_service
506 /usr/lib/obs/server/call-service-in-lxc.sh
509 %defattr(-,root,root)
510 /var/adm/fillup-templates/sysconfig.obs-worker
511 /etc/init.d/obsworker
512 /etc/init.d/obsstoragesetup
513 /usr/sbin/rcobsworker
514 /usr/sbin/rcobsstoragesetup
515 # intentionally packaged in server and api package
516 /var/adm/fillup-templates/sysconfig.obs-server
519 %defattr(-,root,root)
520 %doc dist/{TODO,README.UPDATERS,README.SETUP} docs/openSUSE.org.xml ReleaseNotes-* README COPYING
522 %dir /srv/www/obs/api
523 %dir /srv/www/obs/api/config
524 %dir /srv/www/obs/api/config/initializers
525 %dir /srv/www/obs/api/config/environments
526 %dir /srv/www/obs/api/files
527 /etc/logrotate.d/obs-build.logrotate
528 /etc/logrotate.d/obs-api.logrotate
529 /etc/init.d/obsapidelayed
530 /etc/init.d/obswebuidelayed
531 /etc/init.d/obsapisetup
532 /usr/sbin/rcobsapisetup
533 /usr/sbin/rcobsapidelayed
534 /usr/sbin/rcobswebuidelayed
538 /srv/www/obs/api/files/wizardtemplate.spec
540 /srv/www/obs/api/public
541 /srv/www/obs/api/Rakefile
542 /srv/www/obs/api/README
543 /srv/www/obs/api/script
544 /srv/www/obs/api/test
545 /srv/www/obs/api/vendor
547 # intentionally packaged in server and api package
548 /var/adm/fillup-templates/sysconfig.obs-server
551 # some files below config actually are _not_ config files
552 # so here we go, file by file
555 /srv/www/obs/api/config/boot.rb
556 /srv/www/obs/api/config/routes.rb
557 /srv/www/obs/api/config/environments/development.rb
558 /srv/www/obs/api/config/database.yml.example
559 /srv/www/obs/api/config/environments/production_test.rb
560 /srv/www/obs/api/config/initializers/options.rb
562 %config /srv/www/obs/api/config/environment.rb
563 %config(noreplace) /srv/www/obs/api/config/lighttpd.conf
564 %config(noreplace) /srv/www/obs/api/config/environments/production.rb
565 %config(noreplace) /srv/www/obs/api/config/environments/test.rb
566 %config(noreplace) /srv/www/obs/api/config/environments/stage.rb
567 %config(noreplace) /srv/www/obs/api/config/environments/development_base.rb
568 %config(noreplace) /srv/www/obs/api/config/active_rbac_config.rb
569 %config(noreplace) /srv/www/obs/api/config/options.yml
570 %config(noreplace) /srv/www/obs/api/files/distributions.xml
571 %config(noreplace) /etc/cron.d/obs-api
573 %dir %attr(-,lighttpd,lighttpd) /srv/www/obs/api/log
574 %verify(not size md5) %attr(-,lighttpd,lighttpd) /srv/www/obs/api/log/production.log
575 %attr(-,lighttpd,lighttpd) /srv/www/obs/api/tmp
577 # starting the webui part
578 %dir /srv/www/obs/webui
579 # sqlite3 needs write permissions
580 %dir %attr(-,lighttpd,lighttpd) /srv/www/obs/webui/db
581 /srv/www/obs/webui/app
582 /srv/www/obs/webui/db/migrate
583 /srv/www/obs/webui/db/schema.rb
584 /srv/www/obs/webui/doc
585 /srv/www/obs/webui/lib
586 /srv/www/obs/webui/public
587 /srv/www/obs/webui/Rakefile
588 /srv/www/obs/webui/script
589 /srv/www/obs/webui/test
590 /srv/www/obs/webui/vendor
591 /srv/www/obs/webui/nbproject
593 %dir /srv/www/obs/webui/config
594 %dir /srv/www/obs/webui/config/environments
595 %dir /srv/www/obs/webui/config/initializers
596 /srv/www/obs/webui/config/routes.rb
597 /srv/www/obs/webui/config/environments/development.rb
598 /srv/www/obs/webui/README.rails
599 /srv/www/obs/webui/README.theme
600 /srv/www/obs/webui/config/initializers/options.rb
602 %config /srv/www/obs/webui/config/boot.rb
603 %config /srv/www/obs/webui/config/environment.rb
604 %config(noreplace) /srv/www/obs/webui/config/database.yml
605 %config(noreplace) /srv/www/obs/webui/config/options.yml
606 %config(noreplace) /srv/www/obs/webui/config/environments/production.rb
607 %config(noreplace) /srv/www/obs/webui/config/environments/test.rb
608 %config(noreplace) /srv/www/obs/webui/config/environments/stage.rb
609 %config(noreplace) /srv/www/obs/webui/config/environments/development_base.rb
610 %config(noreplace) /srv/www/obs/webui/config/initializers/theme_support.rb
611 %config(noreplace) /etc/cron.d/obs-webui
613 %dir %attr(-,lighttpd,lighttpd) /srv/www/obs/webui/log
614 %config(noreplace) %verify(not size md5) %attr(-,lighttpd,lighttpd) /srv/www/obs/webui/db/database.db
615 %config(noreplace) %verify(not size md5) %attr(-,lighttpd,lighttpd) /srv/www/obs/webui/log/production.log
616 %attr(-,lighttpd,lighttpd) /srv/www/obs/webui/tmp
618 # these dirs primarily belong to lighttpd:
619 %config(noreplace) /etc/lighttpd/vhosts.d/obs.conf
621 %dir /etc/lighttpd/vhosts.d
622 %config /etc/lighttpd/cleanurl-v5.lua
623 %config /etc/lighttpd/vhosts.d/rails.inc
626 %defattr(-,root,root)
627 /usr/sbin/obs_mirror_project
628 /usr/sbin/obs_project_update
630 %files -n obs-productconverter
631 %defattr(-,root,root)
632 /usr/bin/obs_productconvert
633 /usr/lib/obs/server/bs_productconvert
635 %changelog -n obs-server